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VMware Horizon Client for Mac User Guide

This document, VMware Horizon Client for Mac User Guide, explains how to use VMware 
Horizon® Client™ for Mac to connect to and use remote desktops and published applications.

Horizon Client communicates with a server, which acts as a broker between the client device and 
remote desktops and published applications. You enter credentials into Horizon Client, the server 
authenticates your credentials, and then the server finds the remote desktops and published 
applications that you are entitled to use.

For information about the software installed on your remote desktops, contact your system 
administrator.

This document assumes that Horizon Client for Mac is already installed and configured on your 
Mac. For information about installing and configuring Horizon Client for Mac, see the VMware 
Horizon Client for Mac Installation and Setup Guide document.
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How Do I Log In? 1
Before you can log in and connect to a remote desktop or published application, a system 
administrator at your company must set up your user account. If your system administrator has 
not set up your user account, you cannot use Horizon Client or HTML Access.

If Horizon Client prompts you for a server name and domain name, your system administrator 
must tell you the server name to type and the domain to select. At some companies, Horizon 
Client connects to the correct server and selects the correct domain automatically.

If you do not know your user name or password or how to reset your password, contact the 
system administrator at your company.

When you are ready to log in and get started, see Connect to a Remote Desktop or Published 
Application.
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Connecting to Remote Desktops 
and Published Applications 2
Horizon Client makes it easy to work on remote desktops and published applications from your 
local client device, giving you on-the-go access from any location.

This chapter includes the following topics:

n Set the Certificate Checking Mode

n Allowing Access to macOS Accessibility Features

n Configure Horizon Client to Select a Smart Card Certificate

n Connect to a Remote Desktop or Published Application

n Connecting to a Server When Horizon Client Starts

n Hide the VMware Horizon Client Window

n Add Horizon Client to the Dock

n Autoconnect to a Remote Desktop

n Searching for Remote Desktops and Published Applications

n Switch Remote Desktops or Published Applications

n Open a Recent Remote Desktop or Published Application

n Using a Touch Bar with Server, Desktop, and Application Connections

n Configure Horizon Client to Forget the Server User Name and Domain

n Log Off or Disconnect

n Disconnecting From a Server

Set the Certificate Checking Mode

Server certificate checking occurs for connections between Horizon Client and a server. A 
certificate is a digital form of identification, similar to a passport or a driver's license. Your system 
administrator might ask you to set the certificate checking mode in Horizon Client to make sure 
that you can successfully connect to a server.
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At some companies, an administrator might set the certificate checking mode and prevent you 
from changing it in Horizon Client.

Procedure

1 In the Applications folder, double-click VMware Horizon Client.

2 Select VMware Horizon Client > Preferences from the menu bar.

3 Select the certificate checking mode.

Option Description

Never connect to untrusted servers This setting means that you cannot connect to the server if any of the 
certificate checks fail. An error message lists the checks that failed.

Warn before connecting to 
untrusted servers

This setting means that you can click Continue to ignore the warning if a 
certificate check fails because the server uses a self-signed certificate. For 
self-signed certificates, the certificate name is not required to match the 
server name that you entered in Horizon Client. You can also receive a 
warning if the certificate has expired.

Do not verify server identity 
certificates

This setting means that no certificate checking occurs.

 
4 (Optional) If your environment includes an SSL proxy server, select the Allow connection via 

an SSL Proxy check box.

This setting allows certificate checking for remote desktop and published application 
connections through an SSL proxy server. You cannot enable this setting if you select Do not 
verify server identity certificates.

5 To save your changes, click OK.

What to do next

If you receive a certificate error after setting the certificate checking mode, contact your system 
administrator.

Allowing Access to macOS Accessibility Features

If the client system is running macOS Mojave (10.14), you must grant Horizon Client access to the 
system's accessibility features for optimal performance of the keyboard and mouse inside 
remote desktops and published applications.

When you first start Horizon Client on a macOS Mojave (10.14) client system, Horizon Client 
prompts you to grant access to the system's accessibility features. If you do not grant access at 
that time, you can grant access later by going to System Preferences, selecting Security & 
Privacy, clicking the Privacy tab, and selecting Accessibility.

VMware Horizon Client for Mac User Guide
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Configure Horizon Client to Select a Smart Card Certificate

You can configure a Horizon Client setting to select a local certificate, or the certificate on a 
smart card, when you connect to a server. If you do not configure this setting, you must manually 
select a certificate.

Prerequisites

For your setting to take effect, a Horizon administrator must configure smart card authentication 
on the server and only one certificate must be available on your client system or smart card.

If you have multiple certificates, Horizon Client always prompts you to select a certificate, 
regardless of how you configure this setting.

Procedure

1 In the Applications folder, double-click VMware Horizon Client.

2 Select VMware Horizon Client > Preferences from the menu bar.

3 Click General in the Preferences dialog box.

4 Select Automatically select certificate.

5 Close the Preferences dialog box.

Your changes take effect when the dialog box is closed.

Connect to a Remote Desktop or Published Application

To connect to a remote desktop or published application, you must provide the name of a server 
and supply credentials for your user account.

Prerequisites

Obtain the following information from your system administrator:

n Instructions about whether to turn on a VPN (virtual private network) connection.

n Server name to use for connecting to the server.

n If the port is not 443, the port number to use for connecting to the server.

n Credentials for logging in, such as an Active Directory user name and password, RSA SecurID 
user name and passcode, RADIUS authentication credentials, or smart card personal 
identification number (PIN).

n Domain name for logging in.

n Instructions about whether you can use Touch ID authentication.

If your administrator instructs you to configure the certificate checking mode, see Set the 
Certificate Checking Mode.

VMware Horizon Client for Mac User Guide

VMware, Inc. 10



If you use smart card authentication, you can configure Horizon Client to use a local certificate 
automatically, or to use the certificate on your smart card. See Configure Horizon Client to Select 
a Smart Card Certificate.

Procedure

1 If a VPN connection is required, turn on the VPN.

2 In the Applications folder, double-click VMware Horizon Client.

3 Click Continue to start remote desktop USB and printing services, or click Cancel to use 
Horizon Client without remote desktop USB and printing services.

If you click Continue, you must provide system credentials. If you click Cancel, you can 
enable remote desktop USB and printing services later.

Note   The prompt to start remote desktop USB and printing services appears the first time 
you start Horizon Client. It does not appear again, regardless of whether you click Cancel or 
Continue.

4 Connect to a server.

Option Description

Connect to a new server Click the New Server icon on the Horizon Client Home window, enter the 
server name and port number (if necessary) as instructed by your system 
administrator, and click Connect. An example of using a non-default port is 
view.company.com:1443.

Connect to an existing server Double-click the server shortcut on the Horizon Client Home window.

 
5 If you are prompted for RSA SecurID credentials or RADIUS authentication credentials, enter 

the credentials and click Login.

6 If you are prompted for a user name and password, supply Active Directory credentials.

a Type the user name and password as instructed by your system administrator.

b Select a domain as instructed by your system administrator.

If the Domain drop-down menu is hidden, you must type the user name as 
username@domain or domain\username.

c (Optional) Select the Remember this password check box if this feature is enabled and if 
the server certificate can be fully verified.

d (Optional) Select the Enable Touch ID check box to enable Touch ID authentication.

If Touch ID is enabled and you are logging in for the first time, your Active Directory 
credentials are stored securely on your Mac for future use.

e Click Login.

You might see a message that you must confirm before the login dialog box appears.

7 If you are prompted for Touch ID authentication, place your finger on the Touch ID sensor.

VMware Horizon Client for Mac User Guide
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8 (Optional) If multiple display protocols are configured for a remote desktop, select the 
protocol to use.

VMware Blast provides better battery life and is the best protocol for high-end 3D and 
mobile device users.

Option Description

Select a display protocol for a 
remote desktop

Select the remote desktop name, press Control-click, and select the display 
protocol from the context menu.

Alternatively, you can select Settings from the context menu and select the 
display protocol from the Connect Via drop-down menu in the Settings 
dialog box.

Select a display protocol for a 
published application

Select the published application name, press Control-click, select Settings 
from the context menu, and select the display protocol from the Preferred 
protocol drop-down menu in the Settings dialog box.

 
9 Double-click a remote desktop or published application to connect to it.

If you are connecting to a published desktop, and if the published desktop is already set to 
use a different display protocol, you are prompted to either use the protocol that is set or 
have the system log you off the remote operating system so that a connection can be made 
with the protocol that you selected.

Note   If you are entitled to only one remote desktop on the server, Horizon Client connects 
automatically to that remote desktop.

Results

If a Horizon administrator has enabled the client drive redirection feature, the Sharing dialog box 
might appear. From the Sharing dialog box, you can allow or deny access to files on your local 
system. For more information, see Share Local Folders and Drives.

After you connect to a server for the first time, Horizon Client connects to that server 
automatically the next time you start Horizon Client. To disable this feature, see Connecting to a 
Server When Horizon Client Starts.

Connecting to a Server When Horizon Client Starts

After you connect to a server for the first time, Horizon Client connects automatically to that 
server the next time you start Horizon Client.

To disable this feature, select the server shortcut on the Horizon Client Home window, press 
Control-click, and deselect the Always connect at launch setting.

If there are other server shortcuts on the Horizon Client Home window, you can enable the 
Always connect at launch setting for a different server. You can enable the Always connect at 
launch setting for only one server at a time.

VMware Horizon Client for Mac User Guide
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Hide the VMware Horizon Client Window

You can hide the VMware Horizon Client window after you open a remote desktop or published 
application.

Procedure

u To hide the VMware Horizon Client window after you open a remote desktop or published 
application, click the Close button in the corner of the VMware Horizon Client window.

The VMware Horizon Client icon remains in the Dock.

u To configure a setting that always hides the VMware Horizon Client window after you open a 
remote desktop or published application, perform these steps before you connect to a 
server.

a Select VMware Horizon Client > Preferences from the menu bar and click General in the 
Preferences dialog box.

b Select Hide client window after desktop/application launched.

c Close the Preferences dialog box.

Your changes take effect when the dialog box is closed.

u To show the VMware Horizon Client window after it has been hidden, select Window > Open 
Selection Window from the menu bar, or right-click the VMware Horizon Client icon in the 
Dock and select Show All Windows.

Add Horizon Client to the Dock

You can add Horizon Client to the Dock on the Mac client system.

Procedure

1 In the Applications folder, select VMware Horizon Client.

2 Drag the VMware Horizon Client icon to the Dock.

3 To configure the Dock icon to open Horizon Client at login or to show the icon in the Finder, 
right-click the icon on the Dock, select Options, and select the appropriate command from 
the context menu.

Results

When you quit Horizon Client, the application shortcut remains in the Dock.

Autoconnect to a Remote Desktop

You can configure a server to open a particular remote desktop when you connect to that server. 
You cannot configure a server to open a published application.

VMware Horizon Client for Mac User Guide
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If you are entitled to only one remote desktop on the server, Horizon Client always opens that 
remote desktop when you connect to the server.

Prerequisites

Obtain credentials for connecting to the server, such as a user name and password, RSA SecurID 
user name and passcode, RADIUS authentication user name and passcode, or smart card 
personal identification number (PIN).

Procedure

1 On the Horizon Client Home window, double-click the server icon.

2 If prompted, supply your credentials.

3 Click the Settings button (gear icon) in the upper-right corner of the desktop and application 
selection window.

4 Select the remote desktop in the left pane of the Settings dialog box.

5 Select Autoconnect to this desktop.

Searching for Remote Desktops and Published Applications

After you connect to a server, the available remote desktops and published applications on that 
server appear in the desktop and application selection window. You can search for a particular 
remote desktop or published application by typing in the window.

When you begin to type, Horizon Client highlights the first matching remote desktop or published 
application name. To connect to a highlighted remote desktop or published application, press the 
Enter key. If you continue to type after the first match is found, Horizon Client continues to 
search for matching remote desktops and published applications. If Horizon Client finds multiple 
matching remote desktops or published applications, you can press the Tab key to switch to the 
next match. If you stop typing for two seconds and then begin to type again, Horizon Client 
assumes that you are starting a new search.

Switch Remote Desktops or Published Applications

If you are connected to a remote desktop, you can switch to another remote desktop. You can 
also connect to a published application while you are connected to a remote desktop.

VMware Horizon Client for Mac User Guide
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Procedure

u Select a remote desktop or published application from the same server or from a different 
server.

Option Action

Choose a different remote desktop 
or published application on the 
same server

Perform one of the following actions:

n To keep the current remote desktop and also connect to another remote 
desktop, select Window > VMware Horizon Client from the menu bar 
and double-click the shortcut for the other remote desktop. That remote 
desktop opens in a new window so that you have multiple remote 
desktops open. You can switch between remote desktops from the 
Window menu on the menu bar.

n To close the current remote desktop and connect to another remote 
desktop, select Connection > Disconnect from the menu bar and 
double-click the shortcut for the other remote desktop.

n To open another published application, double-click the shortcut for the 
other published application. That published application opens in a new 
window. You now have multiple published applications open, and you 
can switch between them by clicking in an application window.

Choose a different remote desktop 
or published application on a 
different server

If you are entitled to multiple remote desktops or published applications, so 
that the desktop and application selection window is open, click the 
Disconnect from Server button in the left side of the toolbar in the desktop 
and application selection window and disconnect from the server. If you are 
entitled to only one remote desktop or published application, and the 
desktop and application selection window is not open, you can select File > 
Disconnect from Server from the menu bar and then connect to a different 
server.

 

Open a Recent Remote Desktop or Published Application

You can open recent remote desktops and published applications in Horizon Client.

Recent remote desktops and published applications appear in the order in which they were 
opened. If you are not already connected to the server when you open a recent remote desktop 
or published application, the server login screen appears and you must provide your credentials.

Prerequisites

To use this feature, you must have previously opened a remote desktop or published application. 
If you plan to open a recent desktop or published application from the Dock, VMware Horizon 
Client must be in the Dock. See Add Horizon Client to the Dock.

Procedure

u To open a remote desktop or published application from the Dock, Ctrl-click VMware Horizon 
Client in the Dock and select the remote desktop or published application from the menu.

VMware Horizon Client for Mac User Guide
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u To open a remote desktop or published application from the File menu, start Horizon Client, 
select File > Open Recent, and select the remote desktop or published application from the 
menu.

Using a Touch Bar with Server, Desktop, and Application 
Connections

If the Mac has a Touch Bar, you can use the Touch Bar to add a server, disconnect from a server, 
or connect to a recent remote desktop or published application. This feature requires macOS 
Sierra (10.12) or later.

Before you connect to a server, you can touch the plus (+) icon to add a server. After you 
connect to a server, you can touch the Disconnect icon to disconnect from the server.

If you previously connected to a remote desktop or published application, its name appears on 
the Touch Bar before you connect to a server. You can touch the remote desktop or application 
name to log in to the server and start the remote desktop or published application.

You can add, remove, and reorder the items in the Horizon Client app Touch Bar by selecting 
VMware Horizon Client > Customize Touch Bar.

For information about using the Touch Bar after you connect to a remote desktop or published 
application, see Using a Touch Bar with Remote Desktops and Published Applications.

Configure Horizon Client to Forget the Server User Name 
and Domain

By default, Horizon Client stores the user name and domain that you enter when you log in to a 
server. For increased security, you can configure Horizon Client so that it never remembers the 
server user name and domain.

Procedure

1 Select VMware Horizon Client > Preferences from the menu bar.

2 Click General in the Preferences dialog box.

3 Deselect Remember username and domain.

4 Close the Preferences dialog box.

Your changes take effect when the dialog box is closed.

Log Off or Disconnect

If you disconnect from a remote desktop without logging off, applications in the remote desktop 
might remain open. You can also disconnect from a server and leave published applications 
running.

VMware Horizon Client for Mac User Guide
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You can log off from a remote desktop even if you do not have the remote desktop open. This 
feature has the same result as sending Ctrl+Alt+Del to the remote desktop and then clicking Log 
Off.

Note   The Windows key combination Ctrl+Alt+Del is not supported in remote desktops. Instead, 
select Connection > Send Ctrl-Alt-Del from the menu bar. Alternatively, press Fn-Control-Option-
Delete on an Apple keyboard.

Procedure

u Disconnect from a remote desktop without logging off.

Option Action

Disconnect and quit Horizon Client a Click the Close button in the corner of the window, or select File > Close 
from the menu bar.

b Select VMware Horizon Client > Quit VMware Horizon Client from the 
menu bar.

Disconnect and remain in Horizon 
Client

Click the Disconnect button in the toolbar, or select Connection > 
Disconnect from the menu bar.

 

Note   A Horizon administrator can configure a remote desktop to log off when it is 
disconnected. In this case, any open applications in the remote desktop are closed.

u Log off and disconnect from a remote desktop.

Option Action

From within the remote desktop Use the Windows Start menu to log off.

From the menu bar Select Connection > Log Off from the menu bar.

If you use this procedure, files that are open on the remote desktop are 
closed without being saved first.

 
u Disconnect from a published application.

Option Action

Disconnect from the server and 
leave the published application 
running

Perform one of the following actions:

n Click the Disconnect from Server button in the left side of the toolbar in 
the desktop and application selection window.

n Select File > Disconnect from Server from the menu bar.

Close the published application and 
disconnect from the server

a Quit the published application in the usual manner, for example, click the 
Close button in the corner of the application window.

b Click the Disconnect from Server button in the left side of the toolbar in 
the desktop and application selection window, or select File > 
Disconnect from Server from the menu bar.
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u Log off when you do not have a remote desktop open.

If you use this procedure, files that are open on the remote desktop are closed without first 
being saved.

Option Action

From the Home window a Double-click the server shortcut and supply credentials.

b Select the remote desktop and select Connection > Log Off from the 
menu bar.

From the desktop and application 
selection window

Select the remote desktop and select Connection > Log Off from the menu 
bar.

 

Disconnecting From a Server

After you have finished using a remote desktop or published application, you can disconnect 
from the server.

To disconnect from a server, click the Disconnect from Server icon in the upper-left corner of the 
Horizon Client menu bar.

VMware Horizon Client for Mac User Guide
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Using Remote Desktops and 
Published Applications 3
Horizon Client includes additional features to help you use remote desktops and published 
applications on your local client device.

This chapter includes the following topics:

n Share Local Folders and Drives

n Using the URL Content Redirection Feature

n Using a Touch Bar with Remote Desktops and Published Applications

n Copying and Pasting Text and Images

n Dragging and Dropping

n Using Published Applications

n Sharing Remote Desktop Sessions

n Modify the Horizon Client Shortcuts for Windows Actions

Share Local Folders and Drives

With the client drive redirection feature, you can share folders and drives on the local client 
system with remote desktops and published applications.

Shared drives can include mapped drives and USB storage devices.

When using the client drive redirection feature to share a USB drive with a remote desktop, you 
cannot unplug the device and plug it back in during the remote desktop session.

The client drive redirection feature does not support sharing Microsoft OneDrive, Google Drive, 
and enterprise file storage.

In a Windows remote desktop, shared folders and drives appear in the This PC folder or in the 
Computer folder, depending on the Windows operating system version. In a published 
application, such as Notepad, you can browse to and open a file in a shared folder or drive.
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You can turn on the ability to open local files in published applications directly from your local file 
system. If you select a local file and press Control-click, the Open With menu lists the available 
published applications. You can also open a local file by dragging it into the published application 
window or Dock icon.

If you set a published application as the default application for files that have a certain file 
extension, all files on your local file system that have that file extension are registered with the 
server. You can also turn on the ability to run published applications from the Applications folder.

Note   If a file name contains characters that are invalid in the Windows file system, you cannot 
open the file in a published application. For example, you cannot open a file named test2<.txt in 
Notepad.

The client drive redirection settings apply to all remote desktops and published applications.

Prerequisites

To share folders and drives with a remote desktop or published application, a Horizon 
administrator must enable the client drive redirection feature.

Procedure

1 Open the Preferences dialog box and display the Sharing panel.

Option Description

From the desktop and application 
selection window

Select VMware Horizon Client > Preferences and click Sharing.

From the Sharing dialog box that 
appears when you connect to a 
remote desktop or published 
application

Click the Preferences > Sharing link in the dialog box.

From within a remote desktop 
operating system

Select VMware Horizon Client > Preferences from the menu bar and click 
Sharing.

 
2 Configure the client drive redirection settings.

Option Action

Share a specific folder or drive with 
remote desktops and published 
applications

Click the plus (+) button, browse to and select the folder or drive to share, 
and click Add.

Note   If a USB device is already connected to a remote desktop or 
published application with the USB redirection feature, you cannot share a 
folder on the USB device.

Stop sharing a specific folder or 
drive

Select the folder or drive in the Folder list and click the minus (-) button.

Give remote desktops and published 
applications access to files in your 
home directory

Select the Allow access to home-directory check box.

VMware Horizon Client for Mac User Guide
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Option Action

Share USB storage devices with 
remote desktops and published 
applications

Select the Allow access to removable storage check box. The client drive 
redirection feature shares all USB storage devices inserted in your client 
system and all FireWire and Thunderbolt-connected external drives 
automatically. Selecting a specific device to share is not necessary.

Note   USB storage devices already connected to a remote desktop or 
published application with the USB redirection feature are not shared.

If this check box is deselected, you can use the USB redirection feature to 
connect USB storage devices to remote desktops and published 
applications.

Do not show the Sharing dialog box 
when you connect to a remote 
desktop or published application

Select the Do not show dialog when connecting to a desktop or 
application check box.

If this check box is deselected, the Sharing dialog box appears the first time 
you connect to a remote desktop or published application. For example, if 
you log in to a server and connect to a remote desktop, you see the Sharing 
dialog box. If you then connect to another remote desktop or published 
application, you do not see the dialog box. To see the dialog box again, you 
must disconnect from the server and log in again.

 
3 Configure settings for published applications.

a Click the Settings button (gear icon) in the upper-right corner of the desktop and 
application selector window and select Applications in the left pane.

b To turn on the ability to open local files with published applications from the local file 
system, select Open local files in hosted applications.

c To turn on the ability to run published applications from the Applications folder on the 
client system, select Run hosted applications from your local Applications folder.

What to do next

Verify that you can see the shared folders from within the remote desktop or published 
application.

n In a Windows remote desktop, open File Explorer and look in the This PC folder, or open 
Windows Explorer and look in the Computer folder, depending on the Windows operating 
system version.

n In a published application, select File > Open or File > Save As and navigate to the folder or 
drive.

The folders and drives that you selected for sharing might use one (or more) of the following 
naming conventions.

Naming Convention Example

folder-name on desktop-name jsmith on JSMITH-W03

folder-name (drive-number:) jsmith (Z:) 

folder-name on desktoptop-name (drive-number:) jsmith on JSMITH-W03 (Z:)
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For some Horizon Agent versions, a redirected folder can have two entrances, such as under 
Devices and drives and Network locations in Windows 10, and both entrances can appear at the 
same time. If all the volume labels (from A: through Z:) are already in use, the redirected folder 
has only one entrance.

Using the URL Content Redirection Feature

A Horizon administrator can configure URL links that you click inside a remote desktop or 
published application to open in the default browser on the local client system. The URL link 
might be to a Web page, a phone number, an email address, or another type of link. This feature 
is called URL Content Redirection.

A Horizon administrator can also configure URL links that you click inside a browser or application 
on the local client system to open in a remote desktop or published application. If Horizon Client 
is not already open you click the URL link, it starts and prompts you to log in.

A Horizon administrator might set up the URL Content Redirection feature for security purposes. 
For example, if you are at work and click a link that points to a URL outside your company 
network, the link might be more safely opened in a published application. An administrator can 
configure which published application opens the link.

Each company configures its own URL Content Redirection policies. If you have questions about 
how the URL Content Redirection feature behaves at your company, contact your system 
administrator.

Responding to URL Content Redirection Prompts

The first time you start Horizon Client and connect to a server on which the URL Content 
Redirection feature is configured, Horizon Client prompts you to open the VMware Horizon URL 
Filter application when you click a link for redirection. Click Open to allow the URL to be 
redirected.

Depending on how the URL Content Redirection feature is configured, Horizon Client might 
display an alert message that asks you to change your default Web browser to VMware Horizon 
URL Filter. If you see this prompt, click the Use "VMware Horizon URL Filter" button to allow 
VMware Horizon URL Filter to become the default browser. This prompt appears only once, 
unless you change your default browser after clicking Use "VMware Horizon URL Filter".

Horizon Client might also display an alert message that asks you to select an application when 
you click a URL. If you see this prompt, you can click Choose Application to search for an 
application on the local client system, or click Search App Store to search for and install a new 
application. If you click Cancel, the URL is not opened.
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Using URL Content Redirection with Chrome

If the Chrome browser prompts you to enable the VMware Horizon URL Content Redirection 
Helper extension, click Enable Extension to use the URL Content Redirection feature with the 
Chrome browser. If you click Remove from Chrome, the extension is removed and URLs clicked 
in Chrome are not redirected. You can still install the extension manually from the Chrome Web 
Store.

The first time a URL is redirected from the Chrome browser on the client system, you are 
prompted to open the URL in Horizon Client. If you select the Remember my choice for VMware 
Horizon Client links check box (recommended) and then click Open VMware Horizon Client, this 
prompt does not appear again.

Using a Touch Bar with Remote Desktops and Published 
Applications

You can use a Touch Bar to interact with remote desktops and published applications. This 
feature requires macOS Sierra (10.12) or later.

After you connect to a remote desktop, you can use icons on the Touch Bar to perform the 
following tasks.

n Disconnect, log out, restart or reset, and send Ctrl+Alt+Delete to the remote desktop.

n Enter or exit full-screen mode.

n Bring the desktop and application selection window to the foreground.

n View a list of all the currently open remote desktops and published applications.

n Switch to another open remote desktop or published application.

You can add, remove, and reorder the items in the Horizon Client app Touch Bar by selecting 
VMware Horizon Client > Customize Touch Bar.

Note   The log out, reset, and restart features are available only if a Horizon administrator has 
enabled them. If the remote desktop is in exclusive mode, you cannot use the Touch Bar to enter 
or exit full-screen mode or bring the desktop and application selection window to the 
foreground.

After you connect to a published application, the following icons appear on the Touch Bar.

From left to right, you can use these icons to perform the following tasks:

n Display a list of function keys.

n View the list of open windows for the current published application. You can click a window 
title to switch to that window.

n Zoom (toggles between maximize and restore).
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n Hide all windows of the current published application.

n Minimize the current published application window.

n Bring the application selection window to the foreground.

n View a list of all currently open remote desktops and published applications. You can click the 
remote desktop or published application to bring it to the foreground.

Copying and Pasting Text and Images

By default, you can copy and paste from the client system to a remote desktop or published 
application. You can also copy and paste from a remote desktop or published application to the 
client system, or between two remote desktops or published applications, if a Horizon 
administrator enables these features.

You can copy and paste text and images, including Rich Text Format (RTF).

For example, to copy text on the client system, select the text and press Command-C. To paste 
the text into a remote desktop, press Command-V in the remote desktop.

The copy and paste feature has the following limitations.

n You cannot copy and paste files between a remote desktop and the file system on the local 
client computer.

n If you are copying formatted text, some of the data is text and some of the data is formatting 
information. If you copy a large amount of formatted text or text and an image, when you 
attempt to paste the text and image, you might see some or all the plain text, but no 
formatting or image. This problem occurs because the three types of data are sometimes 
stored separately. For example, depending on the type of document, images might be stored 
as images or as RTF data.

n If the text and RTF data together use less than the maximum clipboard size, the formatted 
text is pasted. Often, the RTF data cannot be truncated, so that if the text and formatting use 
more than the maximum clipboard size amount, the RTF data is discarded, and the plain text 
is pasted.

n If you are unable to paste all the formatted text and images that you selected in one 
operation, you might need to copy and paste smaller amounts in each operation.

Dragging and Dropping

The drag and drop feature works differently depending on how a Horizon administrator 
configures the feature. 

For example, you might be able to drag and drop files, folders, text, rich text, and images 
between the client system and remote desktops and published applications, or you might be able 
to drag and drop only text, rich text, and images from the client system to an open application in 
a remote desktop.
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Dragging Text and Images

You can drag text and images from the client system to an open application in a remote desktop 
or a published application. For example, you can drag text from a browser on the client system 
and drop it into the WordPad application in a remote desktop. Depending on how the drag and 
drop feature is configured, you might also be able to drag text and images from an open 
application in a remote desktop or a published application to the client system.

The following data formats are supported.

n Plain Text (NSPasteboardTypeString)

n Rich Text (NSPasteboardTypeRTF)

n Image (kUTTypeImage)

A Horizon administrator can configure drag and drop behavior. A Horizon administrator can also 
disable this feature.

Dragging Files and Folders

Depending on how a Horizon administrator has configured the drag and drop feature, you might 
be able to drag and drop files and folders between the Mac client system and remote desktops 
and published applications. You can drag and drop multiple files and folders at the same time. A 
progress bar shows the status of the drag and drop operation. 

If you drag a file or folder between the client system and a remote desktop, the file or folder 
appears in the file system on the target system. If you drag a file and drop it into an open 
application, such as Notepad, the text appears in the application. If you drag a file into a new 
email message, the file becomes an attachment to the email message.

By default, dragging and dropping from the client system to remote desktops and published 
applications is enabled, and dragging and dropping from remote desktops and published 
applications to the client system is disabled. A Horizon administrator can configure the drag and 
drop direction.

Tips for Using the Drag and Drop Feature

When using the drag and drop feature, follow these tips.

Note   Depending on how a Horizon administrator configures the drag and drop feature, some 
tips might not apply to your environment.

n You must use the VMware Blast or PCoIP display protocol.

n When a drag and drop operation is in progress, you cannot start a new drag and drop 
operation until after the first drag and drop operation has finished.

n You cannot drag and drop between remote desktops.

n You cannot drag and drop between published applications.
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n If you drag and drop a file or folder between the client system and a remote desktop, the file 
or folder appears in the file system on the target system. If you drag a file and drop it into an 
open application, such as Notepad, the text appears in the application. If you drag a file into a 
new email message, the file becomes an attachment to the email message.

n You can drag and drop multiple files and folders at the same time. A progress bar shows the 
status of the drag and drop operation.

n By default, dragging and dropping from the client system to remote desktops and published 
applications is enabled, and dragging and dropping from remote desktops and published 
applications to the client system is disabled.

n When you drag a file from the client system and drop it into a published application, you 
cannot click Save as to copy the file back to a different file on the client system. You can click 
Save to copy the file back to the same file on the client system.

n If you drag a file from the client system to an application in a remote desktop, the file is 
copied to the remote desktop and you can only edit the copy of the file.

n If you are dragging formatted text, some of the data is text and some of the data is 
formatting information. If you drag a large amount of formatted text, or text and an image, 
when you attempt to drop the text and image, you might see some or all the plain text, but 
no formatting or image. This problem occurs because the three types of data are sometimes 
stored separately. For example, depending on the type of document, images might be stored 
as images or as RTF data.

n If you are dragging both plain text and RTF data, and the total data size is less than the drag 
and drop size threshold, the formatted text is copied. Because RTF data cannot be truncated, 
if the total data size is greater than the drag and drop size threshold, the RTF data is 
discarded and only the plain text (or part of the plain text) is copied.

n If you are unable to drag all the formatted text and images in one operation, you might need 
to drag smaller amounts in each operation.

n A built-in timeout mechanism exists for fault tolerance.

n When you drag and drop a file or folder between different operating systems, the file or 
folder name must be accepted by both operating systems.

Using Published Applications

You can use many Mac functions with published applications.

n When you run a published application, its icon appears in the Dock. You can maximize a 
minimized published application by clicking its icon in the Dock.

n You can keep, open, and quit a published application from its context menu in the Dock. If 
you select Keep in Dock, the published application icon remains in the Dock, even after you 
close all application windows.

n You can open a published application by clicking its icon in the Dock.
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n You can open local files in published applications and run published applications from the 
Applications folder on the client system. To enable these features, see Share Local Folders 
and Drives.

n Flashing Windows taskbar items are forwarded to Horizon Client. For example, if the 
published application is an IM client and you receive a new message, a flashing red dot 
appears on the IM client icon in the Dock.

n You can start voice dictation, minimize, and zoom a published application from the menu bar.

n You can use the Exposé feature to see open published applications, and you can press 
Command-Tab to switch between open published applications.

n You can use standard Mac keyboard shortcuts to interact with published applications. For 
example, you can press Command-W to close an individual application window and 
Command-S to save the current file. You can also use standard Mac keyboard shortcuts to 
copy, cut, and paste text between applications on the Mac and published applications. You 
can customize keyboard shortcut mappings. See Create Keyboard Shortcut Mappings.

n If a published application creates a Windows System Tray item, that item appears in the 
notification area on the menu bar on the Mac client system. You can interact with this item 
from the notification area on the Mac in the same way that you interact with it from the 
System Tray on a Windows system.

Note   When you reclick a redirected System Tray item in the notification area on the Mac, 
the context menu does not disappear.

Saving Documents in a Published Application

With certain published applications, such as Microsoft Word or WordPad, you can create and 
save documents. Where these documents are saved depends on your company's network 
environment. For example, your documents might be saved to a home share mounted on your 
local computer.

Contact your system administrator to find out where documents created in published 
applications are saved in your environment.

Use a Local IME with Published Applications

If you use non-English keyboards and locales, you can use an IME (input method editor) that is 
installed in the local client system to send non-English characters to a published application.

You can use the Input menu in the menu bar on the Mac or keyboard shortcuts to switch to a 
different IME. You do not need to install an IME on the server that hosts the published application.

Note   On a Mac, an IME is called an input source.

When this feature is enabled, the local IME is used. If an IME is installed and configured on the 
server that hosts the published application, that remote IME is ignored.
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Prerequisites

n Verify that one or more IMEs are installed in the client system.

Procedure

1 In the Horizon Client desktop and application selection window, Control-click a published 
application and select Settings.

2 In the Remote Applications pane, select the Extend the local IME to hosted applications 
check box.

3 Use the local IME as you might use it with locally installed applications.

Results

The Input menu appears in the menu bar on the Mac client. When you use a published 
application, you can switch to a different language or IME by using the Input menu or keyboard 
shortcuts. Key combinations that perform certain actions, such as Command-C to copy and 
Command-V to paste, work correctly.

Configure Reconnect Behavior for Published Applications

If you disconnect from a server without closing a published application, Horizon Client prompts 
you to reopen that published application the next time you connect to the server. You can 
change this behavior by modifying the Reconnect Behavior setting in Horizon Client.

Prerequisites

Obtain credentials for connecting to the server, such as a user name and password, RSA SecurID 
user name and passcode, RADIUS authentication user name and passcode, or smart card 
personal identification number (PIN).

Procedure

1 On the Horizon Client Home window, double-click the server icon.

2 If prompted, supply your credentials.

3 Click the Settings button (gear icon) in the upper-right corner of the desktop and application 
selection window.

4 Select Applications in the left pane of the Settings dialog box.
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5 Select an application reconnect behavior option.

These options determine how Horizon Client behaves when a user connects to the server and 
published applications are still running.

Option Description

Ask to reconnect to open 
applications

Horizon Client shows the message You have one or more remote 
applications running. Would you like to open them now? You can respond 
by clicking Reconnect to Applications or Not Now. You can also select the 
Don't show this message again check box to suppress the message in the 
future. This setting is enabled by default.

Reconnect automatically to open 
applications

Horizon Client immediately reopens any running published applications.

Do not ask to reconnect and do not 
automatically reconnect

Horizon Client does not prompt you to reopen running published 
applications, nor does it reopen running published applications. This setting 
has the same effect as the Don't show this message again check box.

 

Results

The new setting takes effect the next time you connect to the server.

Use Multiple Sessions of a Published Application From Different 
Client Devices

When multi-session mode is enabled for a published application, you can use multiple sessions of 
the same published application when you log on to the server from different client devices.

For example, if you open a published application in multi-session mode on client A, and then 
open the same published application on client B, the published application remains open on client 
A and a new session of the published application opens on client B. By comparison, when multi-
session mode is disabled (single-session mode), the published application session on client A 
disconnects and reconnects on client B.

The multi-session mode feature has the following limitations.

n Multi-session mode does not work for applications that do not support multiple instances, 
such as Skype for Business.

n If the application session is disconnected while you are using a published application in multi-
session mode, you are logged off automatically and any unsaved data is lost.

n If the Mac client system goes to sleep while you are connected to a published application in 
multi-session mode, the published application session is not resumed.

n You cannot use the same published application in both single-session mode and multi-session 
mode. For example, if you are using a published application in single-session mode, you must 
quit the application before you can change it to multi-session mode.
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Prerequisites

A Horizon administrator must enable multi-session mode for the published application. You 
cannot enable or change the multi-session mode for a published application unless a Horizon 
administrator allows it.

Procedure

1 Connect to a server.

2 Click the Settings button (gear icon) in the upper-right corner of the desktop and application 
selector window and select Multi-Launch.

If no published applications are available to use in multi-session mode, the Multi-Launch 
setting does not appear.

3 Select the published applications that you want to use in multi-session mode.

If a Horizon administrator has enforced multi-session mode for a published application, you 
cannot change this setting.

Run Published Applications from the Applications Folder

You can configure Horizon Client so that published applications appear in the Applications 
folder on the client system.

If a Horizon administrator has configured one or more category folders for a published 
application, you can optionally configure Horizon Client to show the published application in 
those folders in the Applications folder on the client system.

Prerequisites

Connect to a server.

Procedure

1 Click the Settings button (gear icon) in the upper-right corner of the desktop and application 
selector window and select Applications in the left pane.

2 To turn on the ability to run published applications from the Applications folder on the client 
system, select Run hosted applications from your local Applications folder.

3 (Optional) To show the category folders that are configured for published applications in the 
Applications folder, select Allow automatic shortcuts from the server.

Sharing Remote Desktop Sessions

With the Session Collaboration feature, you can invite other users to join an existing remote 
desktop session. A remote desktop session that is shared in this way is called a collaborative 
session. The user that shares a session with another user is called the session owner, and the 
user that joins a shared session is called a session collaborator.

A Horizon administrator must enable the Session Collaboration feature.
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For information about how the Session Collaboration feature behaves at your company, contact 
your system administrator.

Invite a User to Join a Remote Desktop Session

With the Session Collaboration feature, you can invite users to join a remote desktop session by 
sending collaboration invitations by email, in an instant message (Windows remote desktops 
only), or by copying a link to the clipboard and forwarding the link to users.

You can invite only users that belong to a domain that the server allows for authentication. You 
can invite up to five users by default. A Horizon administrator can change the maximum number 
of users that you can invite.

The Session Collaboration feature has the following limitations.

n If you have multiple monitors, only the primary monitor is shown to session collaborators.

n You must select the VMware Blast display protocol when you create a remote desktop 
session to share. The Session Collaboration feature does not support PCoIP or RDP sessions.

n Anonymous collaboration is not supported. Session collaborators must be identifiable 
through Horizon-supported authentication mechanisms.

n Session collaborators must have Horizon Client 4.7 or later for Windows, Mac, or Linux 
installed, or they must use HTML Access 4.7 or later.

n If a session collaborator has an unsupported version of Horizon Client, an error message 
appears when the user clicks a collaboration link.

n You cannot use the Session Collaboration feature to share published application sessions.

Prerequisites

n The Session Collaboration feature must be enabled and configured.

n To use the email invitation method, an email application must be installed.

n To use the IM invitation method for a Windows remote desktop, Skype for Business must be 
installed and configured.

Procedure

1 Connect to a remote desktop for which the Session Collaboration feature is enabled.

You must use the VMware Blast display protocol.

2 In the system tray in the remote desktop, click the VMware Horizon Collaboration icon, for 

example, .

The collaboration icon might look different, depending on the operating system version.
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3 When the VMware Horizon Collaboration dialog box opens, enter the user name (for 
example, testuser or domain\testuser) or the email address of the user that you want to 
join the remote desktop session.

The first time you enter the user name or email address of a particular user, you must click 
Look up "user", enter a comma (,), or press the Enter key to validate the user. For Windows 
remote desktops, the Session Collaboration feature remembers the user the next time you 
enter the user's user name or email address.

4 Select an invitation method.

Not all invitation methods might be available.

Option Action

Email Copies the collaboration invitation to the clipboard and opens a new email 
message in the default email application. An email application must be 
installed to use this invitation method.

IM (Windows remote desktops only) Copies the collaboration invitation to the 
clipboard and opens a new window in Skype for Business. Press Ctrl+V to 
paste the link into the Skype for Business window. Skype for Business must 
be installed and configured to use this invitation method.

Copy Link Copies the collaboration invitation to the clipboard. You must manually open 
another application, such as Notepad, and press Ctrl+V to paste the 
invitation.

 

Results

After you send an invitation, the VMware Horizon Collaboration icon also appears on the desktop 
and the Session Collaboration user interface turns into a dashboard that shows the current state 
of the collaboration session and enables you to take certain actions.

When a session collaborator accepts your invitation to join a Windows remote desktop session, 
the Session Collaboration feature notifies you and a red dot appears on the VMware Horizon 
Collaboration icon in the system tray. When a session collaborator accepts your invitation to join 
a Linux remote desktop session, a notification appears in the primary session desktop.

What to do next

Manage the remote desktop session in the VMware Horizon Collaboration dialog box. See 
Manage a Shared Remote Desktop Session.

Manage a Shared Remote Desktop Session

After you send a session collaboration invitation, the Session Collaboration user interface turns 
into a dashboard that shows the current state of the shared remote desktop session 
(collaborative session) and enables you to take certain actions.

A Horizon administrator can configure a remote desktop to prevent the hand off of control to a 
session collaborator.
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Prerequisites

Start a collaborative session. See Invite a User to Join a Remote Desktop Session.

Procedure

1 In the remote desktop, click the VMware Horizon Collaboration icon in the system tray.

The names of all session collaborators appear in the Name column and their status appears in 
the Status column.

2 Use the VMware Horizon Session Collaboration dashboard to manage the collaborative 
session.

Option Action

Revoke an invitation or remove a 
collaborator

Click Remove in the Status column.

Hand off control to a session 
collaborator

After the session collaborator joins the session, toggle the switch in the 
Control column to On.

To resume control of the session, double-click or press any key. The session 
collaborator can also give back control by toggling the switch in the Control 
column to Off, or by clicking the Give Back Control button.

Add a collaborator Click Add Collaborators.

End the collaborative session Click End Collaboration. All active collaborators are disconnected.

In Windows remote desktops, you can also end the collaborative session by 
clicking the Stop button next to the VMware Horizon Session Collaboration 
icon. The Stop button is not available in Linux remote desktops.

 

Join a Remote Desktop Session

With the Session Collaboration feature, you can click the link in a collaboration invitation to join a 
remote desktop session. The link might be in an email or instant message, or in a document that 
the session owner forwards to you. Alternatively, you can log in to the server and double-click 
the icon for the session in the remote desktop and application selector window.

This procedure describes how to join a remote desktop session from a collaboration invitation.

When you join a remote desktop session with the Session Collaboration feature, you cannot use 
the following features in the remote desktop session.

n USB redirection

n Real-Time Audio-Video (RTAV)

n Multimedia redirection

n Client drive redirection

n Smart card redirection

n Virtual Printing

n Microsoft Lync redirection
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n File redirection and Keep in Dock functionality

n Clipboard redirection

You also cannot change the remote desktop resolution in the remote desktop session.

Prerequisites

To join a remote desktop session with the Session Collaboration feature, you must have Horizon 
Client 4.7 for Windows, Mac, or Linux installed on the client system, or you must use HTML 
Access 4.7 or later.

Procedure

1 Click the link in the collaboration invitation.

Horizon Client opens on the client system.

2 Enter your credentials to log in to Horizon Client.

After you are successfully authenticated, the collaborative session begins and you can see 
the session owner's remote desktop. If the session owner transfers mouse and keyboard 
control to you, you can use the remote desktop.

3 To return mouse and keyboard control to the session owner, click the VMware Horizon 
Collaboration icon in the system tray and toggle the switch in the Control column to Off, or 
click the Give Back Control button.

4 To leave the collaborative session, click Options > Disconnect.

Modify the Horizon Client Shortcuts for Windows Actions

Horizon Client includes preconfigured shortcut mappings for common Windows actions, including 
Toggle Full Screen, Quit, Hide Application, Cycle Through Windows, and Cycle Through Windows 
in Reverse. It also includes a preconfigured shortcut mapping for Toggle Exclusive Mode. You can 
enable or disable the default shortcuts. You cannot create shortcuts or delete the default 
shortcuts.

Procedure

1 Select VMware Horizon Client > Preferences and click Keyboard & Mouse.

2 Select the Horizon Shortcuts tab.
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3 Modify the default shortcuts.

Option Action

Enable a shortcut Select the On check box next to the shortcut. When you enable a shortcut, 
Horizon Client does not send the shortcut to the remote desktop or 
published application.

Disable a shortcut Deselect the On check box next to the shortcut. When you disable a 
shortcut, Horizon Client sends the shortcut to the remote desktop or 
published application.

Note   The behavior of the shortcut on the remote desktop or published 
application can be unpredictable.

Restore the default settings Click Restore Defaults. Any changes that you made are deleted and the 
default settings are restored.

 
4 Close the Preferences dialog box.

Your changes take effect immediately. You do not need to restart open remote desktops or 
published applications to make the changes take effect.
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Using Server, Remote Desktop, 
and Published Application 
Shortcuts

4
You can reorder and drag and drop server, remote desktop, and published application shortcuts. 
You can also select favorite remote desktop and published application shortcuts and remove 
server shortcuts from the Horizon Client Home window.

This chapter includes the following topics:

n Reordering Shortcuts

n Dragging Shortcuts and URIs

n Select a Favorite Remote Desktop or Published Application

n Removing a Server Shortcut from the Home Window

Reordering Shortcuts

You can reorder server, remote desktop, and published application shortcuts.

Each time you connect to a server, Horizon Client saves a server shortcut to the Home window. 
You can reorder these server shortcuts by selecting a shortcut and dragging it to a new position 
on the Home window.

After you connect to a server, the available remote desktops and published applications on that 
server appear in the desktop and application selection window. Remote desktop shortcuts 
appear first, followed by published application shortcuts. Remote desktop shortcuts and 
published application shortcuts are arranged alphabetically and cannot be rearranged.

When you are in the Favorites view (you clicked the Favorites button in the upper-right corner of 
the desktop and application selection window), you can reorder remote desktop and published 
application shortcuts by selecting a shortcut and dragging it to a new position on the window.

Dragging Shortcuts and URIs

You can drag server, remote desktop, and published application shortcuts and Uniform Resource 
Identifiers (URIs).
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You can drag a server shortcut from the Horizon Client Home window into another app, such as 
Notes. The server shortcut appears as a URI in the other app, for example, vmware-view://
server-address. You can also drag a server address or URI from another app into the Home 
window.

After you connect to a server, you can drag a remote desktop or published application shortcut 
from the Horizon Client desktop and application selection window into another app, such as 
Notes. The shortcut appears as a URI in the other app, for example, vmware-view://server-
name/item-name.

If you drag a server, remote desktop, or published application shortcut from Horizon Client into a 
folder on the Mac, Horizon Client creates a shortcut file in the folder. You can double-click this 
shortcut file to start Horizon Client and connect to the server, remote desktop, or published 
application.

Select a Favorite Remote Desktop or Published Application

You can select favorite remote desktops and published applications. Shortcuts for favorite items 
are identified by a star and appear on the Favorites tab. Favorite items are saved after you log 
off from the server.

Prerequisites

Obtain the credentials for connecting to the server, such as a user name and password or RSA 
SecurID and passcode.

Procedure

1 On the Horizon Client Home window, double-click the server icon.

2 If prompted, supply your RSA user name and passcode, your Active Directory user name and 
password, or both.

3 To select or deselect a favorite remote desktop or published application, perform these 
steps.

Option Action

Select a favorite Select the remote desktop or published application shortcut, press Control-
click, and select Mark as Favorite from the context menu. A star appears in 
the upper-right corner of the remote desktop or published application 
shortcut.

Deselect a favorite Select the remote desktop or published application shortcut, press Control-
click, and deselect Mark as Favorite from the context menu. A star no longer 
appears in the upper-right corner of the remote desktop or published 
application shortcut.
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4 (Optional) To display only favorite remote desktops or published applications, click the 
Favorites button (star icon) in the upper-right corner of the desktop and application selection 
window.

You can click the Favorites button again to display all the available remote desktops and 
published applications.

Removing a Server Shortcut from the Home Window

After you connect to a server, Horizon Client saves a server shortcut to the Home window.

You can remove a server shortcut by selecting the shortcut and pressing the Delete key. 
Alternatively, you can Control-click or right-click the shortcut on the Horizon Client Home window 
and select Delete.

You cannot remove remote desktop or published application shortcuts that appear after you 
connect to a server.
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Using External Devices 5
You can use keyboards, displays, microphones, and other external devices with remote desktops 
and published applications.

This chapter includes the following topics:

n Printing From a Remote Desktop or Published Application

n Use USB Devices

n Create Keyboard Shortcut Mappings

n Modify the Horizon Client Mouse Shortcut Mappings

n Monitors and Screen Resolution

n Using Webcams and Microphones

Printing From a Remote Desktop or Published Application

You can print to a network printer or a locally attached printer from a remote desktop or 
published application.

You can use the Virtual Printing feature or the VMware Integrated Printing feature, depending on 
which feature a Horizon administrator has enabled.

Enabling Virtual Printing in Horizon Client

When you use the VMware Blast display protocol or the PCoIP display protocol, you can use 
printers configured for the Mac client from a remote desktop or published application. You do not 
need to install printer drivers on a remote desktop to use the virtual printing feature.

Note   You do not need to enable the VMware Integrated Printing feature. This feature is enabled 
by default.

You typically enable Virtual Printing the first time you start Horizon Client. Click Continue when 
Horizon Client prompts you to start remote desktop USB and printing services and type your 
system credentials.
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If you do not enable Virtual Printing the first time you start Horizon Client, you can use the 
Connection menu to enable Virtual Printing.

n To enable Virtual Printing before you connect to a remote desktop or published application, 
select VMware Horizon Client > Connection > Start Printing Services. Click Continue and 
type your system credentials.

n To enable Virtual Printing after you connect to a remote desktop or published application, 
select VMware Horizon Client > Connection > Start Printing Services. Click Continue, type 
your system credentials, and reconnect to the remote desktop or published application. If 
you cancel the reconnection, you can select Connection > Enable Printing and Horizon Client 
prompts you to reconnect again.

When the Virtual Printing feature is enabled, the Connection menu displays Printing Enabled.

Note   If you install Horizon Client on a Mac on which VMware Fusion was previously started, 
printing services are already enabled when you start Horizon Client. This behavior occurs 
because VMware Fusion and Horizon Client use some of the same files to implement Virtual 
Printing.

Set Printing Preferences for the Virtual Printing Feature

You can set printing preferences in a remote desktop for the Virtual Printing feature. With the 
Virtual Printing feature, you can use network or locally attached printers from a remote desktop 
without having to install additional printer drivers in the remote desktop. For each printer 
available through this feature, you can set preferences for data compression, print quality, 
double-sided printing, color, and other settings.

After a printer is added on the local client computer, Horizon Client adds that printer to the list of 
available printers in the remote desktop. No further configuration is required. If you have 
administrator privileges, you can install printer drivers on the remote desktop without creating a 
conflict with the Virtual Printing component.

Changes to printing preferences are not persistent. Printing preferences revert to the default 
settings the next time a user connects to a remote desktop.

Important   This feature is not available for the following types of printers.

n USB printers that use the USB redirection feature to connect to a virtual USB port in the 
remote desktop.

You must disconnect the USB printer from the remote desktop to use the Virtual Printing 
feature with it.

n The Windows feature for printing to a file.

Selecting the Print to file check box in a Print dialog box does not work. Using a printer driver 
that creates a file does work. For example, you can use a PDF writer to print to a PDF file.
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Prerequisites

To use Virtual Printing, a Horizon administrator must enable the Virtual Printing feature for the 
remote desktop.

To determine whether the Virtual Printing feature is installed in a remote desktop, verify that the 
C:\Program Files\Common Files\ThinPrint folder exists in the remote desktop file system.

Procedure

1 In the Windows remote desktop, go to Control Panel > Hardware and Sound > Devices and 
Printers.

2 In the Devices and Printers window, right-click the virtual printer and select Printer 
properties from the context menu.

In a remote desktop, a virtual printer might appear as <printer_name>, 
<printer_name>(s<session_ID>) or <printer_name>#:<number>.

3 On the General tab, click Preferences.

4 In the Printing Preferences dialog box, select the different tabs and specify which settings to 
use.

5 To save your changes, click OK.

Set Printing Preferences for the VMware Integrated Printing Feature

You can set printing preferences in a remote desktop for the VMware Integrated Printing feature. 
With the VMware Integrated Printing feature, you can use local or network printers from a 
remote desktop without having to install additional printer drivers in the Windows remote 
desktop. For each printer available through this feature, you can set preferences for data 
compression, print quality, double-sided printing, color, and other settings.

Prerequisites

To use VMware Integrated Printing, a Horizon administrator must enable the VMware Integrated 
Printing feature for the remote desktop.

To determine whether the VMware Integrated Printing feature is installed in a remote desktop, 
verify that the C:\Program Files\Common Files\VMware\Remote Experience\x64\vmware-
print-redir-server.exe and C:\Program Files\Common Files\VMware\Remote Experience
\x64\vmware-print-redir-service.exe files exist in the remote desktop file system.

Procedure

1 In the Windows remote desktop, go to Control Panel > Hardware and Sound > Devices and 
Printers.
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2 In the Devices and Printers window, right-click the virtual printer and select Printer 
properties from the context menu.

In a single-user virtual machine desktop, each virtual printer appears as <printer_name>(vdi). 
By default, in a published desktop or published application, each virtual printer appears as 
<printer_name>(v<session_ID>).

3 On the General tab, click Preferences.

4 In the Printing Preferences dialog box, select the different tabs and specify which settings to 
use.

5 To save your changes, click OK.

Printing From a Remote Desktop to a Local USB Printer

A USB printer is a printer that is attached to a USB port on the local client system. You can send 
print jobs to a USB printer attached to the local client system from a remote desktop.

You can use the USB redirection feature, Virtual Printing feature, or VMware Integrated Printing 
feature to print to a USB printer from a remote desktop. Redirected USB printers and virtual 
printers can work together without conflict.

Using the USB Redirection Feature

To use the USB redirection feature to attach a USB printer to a virtual USB port in a remote 
desktop, the required printer drivers must be installed in the remote desktop as well as on the 
client system.

When you use the USB redirection feature to redirect a USB printer, the USB printer is no longer 
logically attached to the physical USB port on the local client system and it does not appear in 
the list of local printers on the local client system. You can print to the USB printer from the 
remote desktop, but you can no longer print to the USB printer from the local client system.

In a remote desktop, redirected USB printers appear as <printer_name>.

For more information, see Use USB Devices.

Using the Virtual Printing Feature or the VMware Integrated Printing Feature

When you use the Virtual Printing feature or the VMware Integrated Printing feature to send print 
jobs to a USB printer, you can print to the USB printer from both the remote desktop and the 
local client system and you do not need to install printer drivers in the remote desktop.

To use the Virtual Printing feature or the VMware Integrated Printing feature, a Horizon 
administrator must enable the feature in the remote desktop.

For more information, see Set Printing Preferences for the Virtual Printing Feature or Set Printing 
Preferences for the VMware Integrated Printing Feature.
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Use USB Devices

With the USB redirection feature, you can use locally attached USB devices, such as thumb flash 
drives, in a remote desktop or published application.

When you use the USB redirection feature, most USB devices that are attached to the local client 
system become available from menus in Horizon Client. You use these menus to connect and 
disconnect the devices.

The types of USB devices that you can redirect depend on how a Horizon administrator has 
configured the remote desktop or published application.

If you use the client drive redirection feature to share a USB storage device or a folder on a USB 
storage device, you cannot use the USB redirection feature to redirect the device to a remote 
desktop or published application because the device is already shared.

You can connect USB devices to a remote desktop or published application either manually or 
automatically.

Prerequisites

n To use USB devices with a remote desktop or published application, a Horizon administrator 
must enable the USB redirection feature.

n The first time you attempt to connect a USB device, you must provide the Administrator 
password. Horizon Client prompts you for the password.

Some components required for USB redirection that Horizon Client installs must be 
configured, and configuration of these components requires Administrator privileges.

n Become familiar with USB Redirection Limitations.

Procedure

u Manually connect the USB device to a remote desktop.

a The first time you use the USB feature, from the VMware Horizon Client menu bar, click 
Connection > USB > Start remote USB services and provide the Administrator password 
when prompted.

b Connect the USB device to the local client system.

c From the VMware Horizon Client menu bar in the remote desktop, click Connection > USB 
> Connect to a desktop to list USB devices.

d Connect to a remote desktop to list the connected USB devices and select a USB device.

The device is manually redirected from the local system to the remote desktop.
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u Connect the USB device to a published application.

a The first time you use the USB feature, from the VMware Horizon Client menu bar, click 
Connection > USB > Start remote USB services and provide the Administrator password 
when prompted.

b Plug in the USB device.

c Open the published application.

d Click the Settings button (gear icon) in the upper-right corner of the desktop and 
application selection window.

e Select Applications in the left pane of the Settings dialog box.

f Click USB at the top of the right pane of the Settings dialog box.

The available USB devices appear in the left pane.

g Select a USB device and click Connect Device.

If a USB device is already connected to a remote desktop or application, you must 
disconnect the device from the desktop or application before you can select it.

h Select a published application and click Continue.

You can select any running published application. After you select a published 
application, you can use the USB device with the published application.

i After you finish using the published application, open the Settings dialog box again, select 
USB, and select Disconnect to release the USB device from the published application.

You can now use the USB device with your local client system, a remote desktop, or 
another published application.

u Configure Horizon Client to connect USB devices automatically to a remote desktop when 
you plug them in to the local system.

Use the autoconnect feature if you plan to connect devices that use MTP drivers, such as 
Android-based Samsung smart phones and tablets.

a Before you plug in the USB device, start Horizon Client and connect to the remote 
desktop.

b The first time you use the USB feature, from the VMware Horizon Client menu bar, click 
Connection > USB > Start remote USB services and provide the Administrator password 
when prompted.

c From the VMware Horizon Client menu bar in the remote desktop, click Connection > USB 
> Automatically connect when inserted.

d Plug in the USB device.

USB devices that you connect to your local system after you start Horizon Client are 
redirected to the remote desktop.
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u Configure Horizon Client to connect USB devices automatically to a remote desktop when 
Horizon Client starts.

a The first time you use the USB feature, from the VMware Horizon Client menu bar in the 
remote desktop, click Connection > USB > Start remote USB services and provide the 
Administrator password when prompted.

b From the VMware Horizon Client menu bar in the remote desktop, click Connection > USB 
> Automatically connect at startup.

c Plug in the USB device and restart Horizon Client.

USB devices that are connected to the local client system when you start Horizon Client are 
redirected to the remote desktop.

Results

The USB device appears in the remote desktop or published application. A USB device might 
take up to 20 seconds to appear in the remote desktop or published application. The first time 
you connect the device to a remote desktop you might be prompted to install drivers.

If the USB device does not appear in the remote desktop or published application after several 
minutes, disconnect and reconnect the device to the client computer.

What to do next

If you have problems with USB redirection, see the topic about troubleshooting USB redirection 
problems in the Configuring Remote Desktop Features in Horizon 7 document.

USB Redirection Limitations

The USB redirection feature has certain limitations.

n When you access a USB device from a menu in Horizon Client and use the device in a remote 
desktop or published application, you cannot access the USB device on the local device.

n USB devices that do not appear in the menu, but are available in a remote desktop or 
published application, include human interface devices such as keyboards and pointing 
devices. The remote desktop or published application, and the local device, use these devices 
at the same time. Interaction with these USB devices can sometimes be slow because of 
network latency.

n Large USB disk drives can take several minutes to appear in the remote desktop or published 
application.

n Some USB devices require specific drivers. If a required driver is not already installed, you 
might be prompted to install it when you connect the USB device to the remote desktop or 
published application.
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n If you plan to attach USB devices that use MTP drivers, such as Android-based Samsung 
smart phones and tablets, configure Horizon Client so that it connects USB devices to the 
remote desktop or published application automatically. Otherwise, if you try to manually 
redirect the USB device by using a menu item, the device is not redirected unless you unplug 
the device and then plug it in again.

n Webcams are not supported for USB redirection.

n The redirection of USB audio devices depends on the state of the network and is not reliable. 
Some devices require a high data throughput even when they are idle. Audio input and 
output devices work well with the Real-Time Audio-Video feature. You do not need to use 
USB redirection for those devices.

n You cannot format a redirected USB drive in a published desktop unless you connect as an 
administrator user.

Note   Do not redirect USB Ethernet devices to a remote desktop. If the local system is 
connected, the remote desktop can connect to the network. If you set the remote desktop to 
autoconnect USB devices, you can add an exception to exclude the Ethernet connection. For 
information about configuring USB redirection, see the VMware Horizon Client for Mac 
Installation and Setup Guide document.

Create Keyboard Shortcut Mappings

You can customize how remote desktops and published applications interpret Apple keyboard 
shortcuts by creating keyboard shortcut mappings.

When you create a keyboard shortcut mapping, you map an Apple keyboard shortcut to a 
Windows keyboard shortcut. A keyboard shortcut consists of one or more key modifiers, such as 
Control and Shift, and a key code. A key code can be any key on your keyboard, except for a 
modifier key. When you press a mapped keyboard shortcut on your Apple keyboard, the 
corresponding Windows keyboard shortcut or action occurs in the remote desktop or 
application.

If you attempt to map an operating system keyboard shortcut, the results can be unpredictable. 
For more information, see Considerations for Mapping Operating System Keyboard Shortcuts.

Procedure

1 Select VMware Horizon Client > Preferences and click Keyboard & Mouse.

2 Select the Key Mappings tab.
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3 Configure the keyboard shortcut mappings.

Option Action

Delete a keyboard shortcut mapping Select the mapping to delete and click the minus (-) button.

Add a keyboard shortcut mapping a Click the plus (+) button.

b Specify the Apple keyboard shortcut sequence by clicking one or more 
keyboard modifiers and typing a key code in the text box. You can also 
select a key from the drop-down menu. The From: field shows the 
keyboard shortcut that you created.

c Specify the corresponding Windows keyboard shortcut sequence by 
clicking one or more keyboard modifiers and typing a key code in the 
text box. You can also select a key from the drop-down menu. The To: 
field shows the keyboard shortcut that you created.

d To save your changes, click OK.

The keyboard shortcut mapping is enabled by default (the On check box 
next to the keyboard shortcut mapping is selected).

Modify a keyboard shortcut 
mapping

Double-click the mapping and make your changes.

n To modify the Apple keyboard shortcut sequence, click one or more 
keyboard modifiers and type a key code in the text box. You can also 
select a key from the drop-down menu.

n To modify the corresponding Windows keyboard shortcut sequence, 
click one or more keyboard modifiers and type a key code in the text 
box. You can also select a key from the drop-down menu.

To save your changes, click OK.

Disable a keyboard shortcut 
mapping

Deselect the On check box next to the keyboard shortcut mapping. When 
you disable a keyboard shortcut mapping, Horizon Client does not send the 
Apple keyboard shortcut to the remote desktop or application.

Enable or disable language-specific 
key mappings

Select or deselect the Enable Language Specific Key Mappings check box. 
The check box is selected by default.

Restore the default mappings Click Restore Defaults. Any changes that you made to the default keyboard 
shortcut mappings are deleted and the default mappings are restored.

 
4 Close the Preferences dialog box.

Your keyboard shortcut mapping changes take effect immediately. You do not need to 
restart open remote desktops or published applications to make the changes take effect.

Considerations for Mapping Operating System Keyboard Shortcuts

Mac and Windows both include default keyboard shortcuts. For example, Command-Tab and 
Command-Space bar are common keyboard shortcuts on Mac systems and Ctrl+Esc and Alt
+Enter are common keyboard shortcuts on Windows systems. If you attempt to map one of 
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these operating system keyboard shortcuts in Horizon Client, the behavior of the shortcut on the 
Mac client system and in the remote desktop or published application can be unpredictable.

n If you map a keyboard shortcut, how the shortcut behaves on the Mac client system depends 
on how the operating system manages the shortcut. For example, the keyboard shortcut 
might trigger an action in the operating system and Horizon Client might not respond to the 
shortcut. Alternatively, the keyboard shortcut might trigger an action in both the operating 
system and Horizon Client.

n Before you map a Mac keyboard shortcut in Horizon Client, you must disable the shortcut in 
System Preferences on the Mac client system. Not all Mac keyboard shortcuts can be 
disabled.

n If you map a Windows keyboard shortcut in Horizon Client, the mapped action occurs when 
you use the shortcut in the remote desktop or published application.

n For published applications, Windows shortcuts that include the Windows key are disabled by 
default and do not appear on the Horizon Client Keyboard Preferences dialog box. If you 
create a mapping for one of these disabled keyboard shortcuts, the shortcut appears in the 
Keyboard Preferences dialog box.

For a list of the default Mac keyboard shortcuts, go to the Apple support website (http://
support.apple.com). For a list of the default Windows shortcuts, go to the Microsoft Windows 
website (http://windows.microsoft.com).

Modify the Horizon Client Mouse Shortcut Mappings

You can configure a single-button Apple mouse to send a right-click and a middle-click to remote 
desktops and published applications. You can modify, enable, or disable the default mouse 
shortcut mappings. You cannot create mouse shortcut mappings, or delete the default mouse 
shortcut mappings.

Procedure

1 Select VMware Horizon Client > Preferences and click Keyboard & Mouse.

2 Select the Mouse Shortcuts tab.

3 Modify the mouse shortcut mappings.

Option Action

Modify a mouse shortcut mapping Double-click the mapping and make your changes. To save your changes, 
click OK .

Disable a mouse shortcut mapping Deselect the On check box next to the mouse shortcut mapping. When you 
disable a mouse shortcut mapping, Horizon Client does not send the mouse 
shortcut to the remote desktop or published application.
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Option Action

Enable a mouse shortcut mapping Select the On check box next to the mouse shortcut mapping. When you 
enable a mouse shortcut mapping, Horizon Client sends the mouse shortcut 
to the remote desktop or published application.

Restore the default settings Click Restore Defaults. Any changes that you made to the default mouse 
shortcut mappings are deleted and the default mappings are restored.

 
4 Close the Preferences dialog box.

Your mouse shortcut mapping changes take effect immediately. You do not need to restart 
open remote desktops or published applications to make the changes take effect.

Monitors and Screen Resolution

When you use the VMware Blast display protocol or the PCoIP display protocol, you can extend 
a remote desktop to multiple monitors. If you have a Mac with Retina Display, you can see the 
remote desktop in full resolution.

With the VMware Blast display protocol or the PCoIP display protocol, a remote desktop screen 
resolution of 4K (3840 x 2160) is supported. The number of 4K displays that are supported 
depends on the hardware version of the desktop virtual machine and the Windows version.

Hardware Version Windows Version
Number of 4K Displays 
Supported

10 (ESXi 5.5.x compatible) 7, 8, 8.x, 10 1

11 (ESXi 6.0 compatible) 7

(3D rendering feature disabled and Windows Aero disabled)

3

11 7

(3D rendering feature enabled)

1

11 8, 8.x, 10 1

13 or 14 7, 8, 8.x, 10

(3D rendering feature enabled)

1

13 or 14 7, 8, 8.x, 10 4

Using Full-Screen Mode with Multiple Monitors

When a remote desktop window is open, you can use the Window > Enter Full Screen menu 
item or the expander arrows in the upper-right corner of the remote desktop window to extend 
the remote desktop across multiple monitors. You can select the Window > Use Single Display in 
Full Screen menu item to make the remote desktop fill only one monitor.

The monitors do not have to be in the same mode. For example, if you are using a laptop that is 
connected to an external monitor, the external monitor can be in portrait mode or landscape 
mode.
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You can select a full-screen option from the Settings dialog box after you connect to a server 
and before you open a remote desktop. Click the Settings button (gear icon) in the upper-right 
corner of the desktop and application selection window, select the remote desktop, and select a 
full-screen option from the Full Screen drop-down menu.

You can use the selective multiple-monitor feature to display a remote desktop window on a 
subset of your monitors. For more information, see Select Specific Monitors to Display a Remote 
Desktop.

Using Remote Desktops with Split View

With Split View, which is supported in El Capitan (10.11) and later, you can fill your Mac screen 
with two applications without manually moving and resizing windows. You can use Split View 
with remote desktops in full-screen mode (Full Screen or Use Single Display in Full Screen 
option).

Using a High-Resolution Mac with Retina Display

If you use the VMware Blast display protocol or the PCoIP display protocol, Horizon Client 
supports high resolutions for client systems that support Retina Display. After you connect to a 
remote desktop, you can select the Connection > Resolution > Full Resolution menu item to 
enable high-resolution mode. This menu item appears only if the client system supports Retina 
Display.

In high-resolution mode, the DPI Synchronization feature ensures that the remote desktop's DPI 
setting matches the client system's DPI setting. For more information, see Using DPI 
Synchronization.

Using DPI Synchronization

The DPI Synchronization feature ensures that the DPI setting in a remote desktop matches the 
client system's DPI setting.

The DPI Synchronization feature has the following requirements.

n The client system must support Retina Display.

n Full-resolution mode (Connection > Resolution > Full Resolution) must be selected in the 
remote desktop.

n If you use multiple monitors, the Retina Display must be the primary window in system 
preferences. You cannot have more than one display in full-screen mode.

A Horizon administrator can disable the DPI synchronization feature.

If DPI synchronization is disabled, display scaling is used. The Display Scaling feature scales the 
remote desktop appropriately.
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Following are tips for using the DPI Synchronization feature.

n If you change the DPI setting on the client system, but the DPI setting does not change in the 
remote desktop, you might need to log out and log in again to make Horizon Client aware of 
the new DPI setting on the client system.

n If you start a remote session on a client system that has a DPI setting of more than 100 
percent, and then use the same session on another client system that has a different DPI 
setting of more than 100 percent, you might need to log out and log back in to the remote 
session on the second client system to make DPI synchronization work on the second client 
system.

n If you connect to an active remote session in full-resolution mode, Horizon Client scales the 
resolution to be similar to when DPI Synchronization is enabled, but icons are not as clear. If 
you switch from normal to full-resolution mode in an active remote session, Horizon Client 
prompts you to log off from the remote session for the resolution change to take effect.

n If you use a non-Retina Display computer when you start a remote session, and then use a 
Retina Display computer to connect to the same session, the remote session cannot change 
to the new DPI setting until after you log off.

Select Specific Monitors to Display a Remote Desktop

If you have two or more monitors, you can select the monitors on which to display a remote 
desktop window. For example, if you have two monitors, you can specify that the remote 
desktop window appears on only one of those monitors.

You can select up to four adjacent monitors.

Prerequisites

You must have two or more monitors.

Procedure

1 Start Horizon Client and connect to a server.

2 In the desktop and application selector window, right-click the remote desktop and select 
Settings.

3 From the Connect Via drop-down menu, select PCoIP or VMware Blast.

4 Select Use Selective Displays from the Full Screen drop-down menu.

Thumbnails of the monitors that are currently connected to the client system appear under 
Display Arrangement. The display topology matches the display settings on the client 
system.

5 To select or deselect a monitor on which to display the remote desktop window, click a 
thumbnail.

When you select a monitor, its thumbnail changes color. If you violate a display selection rule, 
a warning message appears.
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6 Connect to the remote desktop.

Your changes are applied immediately when you connect to the remote desktop. The remote 
desktop enters full-screen mode on the displays that you selected.

Select Specific Monitors to Display Published Applications

If you have two or more monitors, you can select the monitors on which to display published 
application windows. For example, if you have three monitors, you can specify that published 
application windows appear on only two of those monitors.

You can select up to four adjacent monitors. The monitors can be side by side, or stacked 
vertically. For example, you might configure two rows of two monitors each.

Prerequisites

You must have two or more monitors.

Procedure

1 Start Horizon Client and connect to a server.

2 Click the Settings button (gear icon) in the upper-right corner of the desktop and application 
selection window.

3 Select Applications in the left pane of the Settings dialog box.

4 Click the Display tab.

Thumbnails of the monitors that are currently connected to the client system appear under 
Display Arrangement. The display topology matches the display settings on the client 
system.

5 To select or deselect a monitor on which to display published applications, click a thumbnail.

When you select a monitor, its thumbnail changes color. If you violate a display selection rule, 
a warning message appears.

Using Exclusive Mode

Exclusive mode is similar to full-screen mode in that the remote desktop fills the screen. With 
exclusive mode, unlike full-screen mode, the VMware Horizon Client menu bar and Dock do not 
appear when you move your pointer to the edges of the screen.

To enter exclusive mode, open a remote desktop in windowed mode, press and hold down the 
Option key, and select Window > Enter Exclusive Mode.

When a remote desktop is in windowed mode, you can also press Command-Control-Option-F to 
enter exclusive mode. To exit exclusive mode, press Command-Control-Option-F again.

Note   If you do not press and hold down the Option key, the Enter Full Screen menu item 
appears instead of the Enter Exclusive Mode menu item. If the remote desktop is in full-screen 
mode, you cannot select the Enter Excusive Mode menu item.
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To use exclusive mode with two monitors, before you open the remote desktop, select Use All 
Displays from the Settings dialog box, and then open the desktop and enter exclusive mode. To 
use exclusive mode with a single monitor, before you open the remote desktop, select Use 
Single Display from the Settings dialog box, and then connect to the remote desktop and enter 
exclusive mode.

To open the Settings dialog box, click the Settings button (gear icon) in the upper-right corner of 
the desktop and application selection window, select the remote desktop, and select an option 
from the Full Screen drop-down menu.

Customize the Display Resolution and Display Scaling for a Remote 
Desktop

You can use Horizon Client to customize the display resolution and display scaling for a remote 
desktop. The display resolution determines the clarity of the text and images. At higher 
resolutions, such as 1600 x 1200 pixels, items appear sharper. Display scaling, which is 
represented as a percentage, increases or decreases the size of text, icons, and navigation 
elements.

Custom display resolution and display scaling settings are stored only on the local client system. 
If you log in to the remote desktop from a different system, the settings are not applied.

This feature has the following limitations and considerations.

n Customizing the display resolution for a remote desktop is not supported in multiple-monitor 
mode.

n If you select a custom resolution that is higher than the client resolution, Horizon Client 
resizes the remote desktop window to fit the client window. If you select a custom resolution 
that is lower than the client resolution, black bars appear in the remote desktop window.

n If you customize the display resolution during a remote desktop session, your changes take 
effect immediately. If you customize display scaling during a remote desktop session, you 
must log out and log back in to make your changes take effect.

n The Horizon Client Connection > Resolution menu is available only if you select automatic 
resolution. For more information, see Using a High-Resolution Mac with Retina Display.

Procedure

1 Start Horizon Client and connect to a server.

2 In the desktop and application selector window, right-click the remote desktop and select 
Settings.

3 Click the Display tab.
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4 To customize the display resolution, select a resolution from the Resolution drop-down 
menu.

If you select Automatic (the default setting), Horizon Client fits the remote desktop to the 
client window size. If the remote desktop does not support the display resolution that you 
select, it uses the default setting.

5 To customize display scaling, select a scaling size from the Scaling drop-down menu.

If you select Automatic (the default setting), Horizon Client sets the display scaling 
percentage based on the display resolution that you select.

Using Webcams and Microphones

With the Real-Time Audio-Video feature, you can use the local client system's webcam or 
microphone in a remote desktop or published application. Real-Time Audio-Video is compatible 
with standard conferencing applications and browser-based video applications. It supports 
standard webcams, audio USB devices, and analog audio input.

When You Can Use a Webcam with the Real-Time Audio-Video 
Feature

If a Horizon administrator has configured the Real-Time Audio-Video feature, you can use a 
webcam that is built in or connected to the client computer in a remote desktop or published 
application. You can use the webcam in conferencing applications such as Skype, Webex, or 
Google Hangouts.

During the setup of an application such as Skype, Webex, or Google Hangouts on a remote 
desktop, you can select input and output devices from menus in the application.

For remote desktops and published applications, a redirected webcam is named VMware Virtual 
Webcam in the application.

For many applications, you do not need to select an input device.

When the client computer uses the webcam, the remote session can use it at the same time. 
Also, if the remote session uses the webcam, the client computer can use it at the same time.

Note   If you use a USB webcam, do not connect it from the Connection > USB menu in Horizon 
Client. Doing so routes the device through USB redirection and the performance is not usable for 
video chat.

If more than one webcam is connected to the local client computer, you can configure a 
preferred webcam to use in remote sessions.

Select a Default Microphone on the Mac Client

If you have multiple microphones on the Mac client, the remote desktop uses only one 
microphone. You can use the System Preferences on the Mac client to specify the default 
microphone in the remote desktop.
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With the Real-Time Audio-Video feature, audio input devices and audio output devices work 
without using USB redirection and the required network bandwidth is greatly reduced. Analog 
audio input devices are also supported.

This procedure describes how to select a microphone from the user interface of the Mac client. 
You can also configure a preferred microphone by using the Mac defaults system. For more 
information, see the VMware Horizon Client for Mac Installation and Setup Guide document.

Important   When you use a USB microphone, do not connect it from the Connection > USB 
menu in Horizon Client. Doing so routes the device through USB redirection and the device 
cannot use the Real-Time Audio-Video feature.

Prerequisites

n Verify that you have a USB microphone, or another type of microphone, installed and 
operational on the Mac client.

n Use the VMware Blast display protocol or the PCoIP display protocol for the remote desktop.

Procedure

1 On the Mac client, select Apple menu > System Preferences and click Sound.

2 Open the Input pane of Sound preferences.

3 Select the microphone that you prefer to use.

Results

The next time that you connect to a remote desktop and start a call, the remote desktop uses 
the default microphone that you selected on the Mac client.

Allowing Access to Webcams and Microphones

When you first use a webcam or microphone in a remote session on a macOS Mojave (10.14) 
client system, you are prompted to grant access to the system's camera and microphone 
features.

If you do not grant access at that time, you can grant access later by going to System 
Preferences, selecting Security & Privacy, clicking the Privacy tab, and selecting Camera or 
Microphone.
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Upgrade Horizon Client Online 6
You can configure Horizon Client to look for and install updates each time it starts. You can also 
look for and install updates manually.

If Horizon Client detects a new version, you can download and install the new version, have 
Horizon Client remind you to install the new version the next time it starts, or skip the new 
version. If you skip a new version when looking for updates manually, the automatic update 
process also skips that version.

Procedure

u To configure Horizon Client to look for and install updates each time it starts, select VMware 
Horizon Client > Preferences and select the Automatically check for updates check box.

The Automatically check for updates check box is selected by default.

u To look manually for and install an update, select VMware Horizon Client > Check for 
Updates.
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Troubleshooting Horizon Client 7
You can solve most problems with Horizon Client by restarting or resetting remote desktops or 
published applications, or by reinstalling Horizon Client.

This chapter includes the following topics:

n Restart a Remote Desktop

n Reset Remote Desktops or Published Applications

n Uninstalling Horizon Client

n Connecting to a Server in Workspace ONE Mode

Restart a Remote Desktop

If the remote desktop operating system stops responding, you might need to restart a remote 
desktop. Restarting a remote desktop is similar to using the Windows operating system restart 
command. The remote desktop operating system usually prompts you to save any unsaved data 
before it restarts.

You can restart a remote desktop only if a Horizon administrator has enabled the restart feature 
for the remote desktop.

Procedure

u In the desktop and application selection window, select the remote desktop shortcut, press 
Control-click, and select Restart from the context menu.

Results

The operating system in the remote desktop restarts and Horizon Client disconnects and logs off 
from the remote desktop.

What to do next

Wait an appropriate amount of time for the system to restart before you attempt to reconnect to 
the remote desktop.

If restarting the remote desktop does not solve the problem, you might need to reset the remote 
desktop. See Reset Remote Desktops or Published Applications.
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Reset Remote Desktops or Published Applications

You might need to reset a remote desktop if the desktop operating system stops responding and 
restarting the remote desktop does not solve the problem.

Resetting a remote desktop is the same as pressing the Reset button on a physical PC to force 
the PC to restart. Any files that are open on the remote desktop are closed and are not saved.

Resetting published applications quits all open applications.

Resetting published applications quits the applications without saving any unsaved data. All open 
published applications are closed.

You can reset a remote desktop only if a Horizon administrator has enabled the reset feature for 
the remote desktop.

Procedure

u Use the Reset command.

Option Action

Reset a remote desktop from the 
desktop and application selection 
window

Select the remote desktop name, press Control-click, and select Reset from 
the context menu.

Reset published applications from 
the desktop and application 
selection window

Click the Settings button (gear icon) in the upper-right corner of the 
window, select Applications in the left pane, click Reset, and click Continue.

 

Results

When you reset a remote desktop, the operating system in the remote desktop restarts and 
Horizon Client disconnects and logs off from the remote desktop. When you reset published 
applications, the published applications quit.

What to do next

Wait an appropriate amount of time for system to restart before attempting to reconnect to the 
remote desktop or published application.

Uninstalling Horizon Client

Sometimes you can resolve problems with Horizon Client by uninstalling and reinstalling Horizon 
Client.

To uninstall Horizon Client, use the same method that you use to uninstall any application.

Drag the VMware Horizon Client application from the Applications folder to the Trash and 
empty the trash.

After Horizon Client is uninstalled, you can reinstall it.
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Connecting to a Server in Workspace ONE Mode

You cannot connect to a server directly through Horizon Client, or your remote desktop and 
published application entitlements are not visible in Horizon Client.

Problem

n When you try to connect to the server directly through Horizon Client, Horizon Client 
redirects you to the Workspace ONE portal.

n When you open a remote desktop or published application through a URI or shortcut, or 
when you open a local file through file association, the request redirects you to the 
Workspace ONE portal for authentication.

n After you open a remote desktop or published application through Workspace ONE and 
Horizon Client starts, you cannot see or open other entitled remote desktops or published 
applications in Horizon Client.

Cause

Beginning with Horizon 7 version 7.2, a Horizon administrator can enable Workspace ONE mode 
on a Connection Server instance. This behavior is normal when Workspace ONE mode is enabled 
on a Connection Server instance.

Solution

Use Workspace ONE to connect to a Workspace ONE enabled server and access your remote 
desktops and published applications.
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